Essays.club - Ensayos gratis, notas de cursos, notas de libros, tareas, monografías y trabajos de investigación
Buscar

Escribir un programa que pida al usuario que introduzca dos números reales y que imprima en la pantalla cuál es el mayor, y si son iguales que imprima el siguiente mensaje “estos números son iguales”.

Enviado por   •  3 de Septiembre de 2018  •  1.053 Palabras (5 Páginas)  •  178 Visitas

Página 1 de 5

...

readln (a);

writeln ('Inserta el segundo valor');

readln (b);

writeln ('Inserta el tercer valor');

readln (c);

SUMA:=a+b+c;

writeln ('SUMA:',SUMA:0:0);

PRODUCTO:=a*b*c;

writeln ('PRODUCTO:',PRODUCTO:0:0);

PROMEDIO:=a+b+c/3;

writeln ('PROMEDIO:',PROMEDIO:0:2);

if (a>b) and (a>c)

then writeln ('El mayor de los 3 números es:',a)

else

if (b>a) and (b>C)

then writeln ('El mayor de los 3 números es:',b)

else

if (c>a) and (c>b)

then writeln ('El mayor de los 3 números es:',c)

if (a

then writeln ('El menor es:',a)

else

if (b

then writeln ('El menor es:',b)

else

if (c

then writeln ('El menor es:',c);

else

writeln ('Los numeros son iguales')

readln

end.

EJERCICIO 3.

- Escribir un programa que pida 5 numeros al usuario, el programa deberá determinar cuál número es el más pequeño y cuál el más grande e imprimirlos en la pantalla.

Algoritmo.

INICIO

1.- Pedirle cinco números al usuario (a,b,c,d,e)

2.-Hacer la comparación de cuál es el más grande

3.- Mostrar resultado

4.-Hacer la comparación de cuál es el más pequeño

5.-Mostrar resultado

FIN

Diagrama de Flujo.

[pic 4]

Pseudocódigo.

Algoritmo Ejercicio3

Escribir 'Inserte 5 valoers'

Leer a

Leer b

Leer c

Leer d

Leer e

Si a

Escribir 'El número más pequeño es el:',a

Sino

Si b

Escribir 'El número más pequeño es el:',b

Sino

Si c

Escribir 'El número más pequeño es el:',c

Sino

Si d

Escribir 'El número más pequeño es el:',d

Sino

Si e

Escribir 'El número más pequeño es el:',e

Sino

Escribir 'Los numeros son iguales'

FinSi

FinSi

FinSi

FinSi

FinSi

Si a>b Y a>c Y a>d Y a>e Entonces

Escribir 'El número más grande es el:',a

Sino

Si b>a Y b>c Y b>d Y b>e Entonces

Escribir 'El número más grande es el:',b

Sino

Si c>a Y c>b Y c>d Y c>e Entonces

Escribir 'El número más grande es el:',c

Sino

Si d>a Y d>b Y d>c Y d>e Entonces

Escribir 'El número más grande es el:',d

Sino

Si e>a Y e>b Y e>c Y e>d Entonces

Escribir 'El número más grande es el:',e

Sino

Escribir 'Los numeros son iguales'

FinSi

FinSi

FinSi

FinSi

FinSi

FinAlgoritmo

Código Fuente.

EJERCICIO 4.

- Escribir un programa que lea un número entero y escriba en la pantalla si es par o impar.

Algoritmo

INICIO

1.- Pedirle al usuario un número

2.-Dividir el número entre dos para saber

...

Descargar como  txt (9.2 Kb)   pdf (64.6 Kb)   docx (23.3 Kb)  
Leer 4 páginas más »
Disponible sólo en Essays.club