Essays.club - Ensayos gratis, notas de cursos, notas de libros, tareas, monografías y trabajos de investigación
Buscar

ALGORITMO INGRESOS

Enviado por   •  17 de Septiembre de 2018  •  Prácticas o problemas  •  290 Palabras (2 Páginas)  •  42 Visitas

Página 1 de 2

ALGORITMO 1

INGRESOS

roceso ingreso

Escribir " Ingrese su nombre:"

Leer nombre

Escribir " Tipo de turno (diurno o nocturno):"

Leer tipo

Escribir "¿Que empleado es?:"

Leer empleado

Escribir " Horas trabajadas"

Leer horas

Escribir ""

Si tipo = "diurno" Entonces

pago = horas * 1.50

FinSi

Si tipo = "nocturno" Entonces

pago = horas * 2.50

Finsi

Si (empleado = "empleado nominado") y (tipo = "diurno") Entonces

pago = horas * 2.00

Finsi

Si (empleado = "empleado nominado") y (tipo = "nocturno") Entonces

pago = horas * 4.00

Finsi

Escribir nombre, ", su pago es de:", pago;

FinProceso

VIAJES

Proceso viaje

Escribir "Ingrese distanca de ida en km"

leer dist1

Escribir "Ingrese distancia de vuelta en km"

leer dist2

Escribir "¿Cuantos dias duró su estadía?"

leer est

distT <- dist1+dist2

preciob <- (distT*0.17)

Si distT>800 Y est>7 entonces

Escribir "El precio original es de: $", preciob

descuento <- preciob*0.30

costov <- preciob-descuento

sino

costov = preciob

FinSi

Escribir "El billete costará: $", costov

Escribir "dame 4 numeros"

...

Descargar como  txt (1.7 Kb)   pdf (40.5 Kb)   docx (11.1 Kb)  
Leer 1 página más »
Disponible sólo en Essays.club