Essays.club - Ensayos gratis, notas de cursos, notas de libros, tareas, monografías y trabajos de investigación
Buscar

LABORATORIO CICLOS FOR - MIENTRAS

Enviado por   •  7 de Diciembre de 2018  •  3.280 Palabras (14 Páginas)  •  29 Visitas

Página 1 de 14

...

Definir suma Como Entero

c

Mientras c

Escribir "ingrese los numeros para sumarlos"

leer num

Si c>5 Entonces

suma

Fin Si

c

Fin Mientras

Escribir "las suma de los ultimos numeros", suma

FinAlgoritmo

PARA:

Algoritmo sin_titulo

definir num Como Entero

definir c, a, b Como Entero

Definir suma Como Entero

Para c

Escribir "ingrese los numeros para sumarlos"

Leer num

Si c>5 Entonces

suma

Fin Si

Fin Para

Escribir "las suma de los ultimos numeros", suma

FinAlgoritmo

- Realizar un programa que lea los lados de n triángulos, e informar:

a) De cada uno de ellos, qué tipo de triángulo es: equilátero (tres lados iguales), isósceles (dos lados iguales), o escaleno (ningún lado igual)

b) Cantidad de triángulos de cada tipo.

c) Tipo de triángulo que posee menor cantidad.

MIENTRAS:

Algoritmo sin_titulo

definir l1, l2, l3 Como Entero

definir cant1, cant2, cant3 Como Entero

definir c, n como entero

Escribir "ingrese los lados de n de los triangulos";

leer n

c

Mientras c

escribir "ingrese los lados uno de los triangulos";

leer l1

escribir "ingrese los lados dos de los triangulos";

leer l2

escribir "ingrese los lados tres de los triangulos";

leer l3

Si l1=l2 & l1=l3 & l2=l3 Entonces

cant1

Sino

Si l1=l2 & l2=l1 Entonces

cant2

Sino

cant3

Fin Si

Fin Si

c

Fin Mientras

Escribir "triangulos equilateros", cant1

escribir "triangulos isoceles", cant2

Escribir "triangulos escalenos", cant3

Si cant1

Escribir "hubo menos triangulos equilatero"

Sino

Si cant2

Escribir "hubo menos triangulos isoceles"

Sino

Escribir "hubo menos triangulos escalenos"

Fin Si

Fin Si

FinAlgoritmo

PARA:

Algoritmo sin_titulo

definir l1, l2, l3 Como Entero

definir cant1, cant2, cant3 Como Entero

definir c, n como entero

Escribir "ingrese los lados de n de los triangulos";

leer n

Escribir n

Para c

escribir "ingrese los lados uno de los triangulos";

leer l1

escribir "ingrese los lados dos de los triangulos";

leer l2

escribir "ingrese los lados tres de los triangulos";

leer l3

Si l1=l2 & l1=l3 & l2=l3 Entonces

cant1

Sino

Si l1=l2 & l2=l1 Entonces

cant2

Sino

cant3

Fin Si

Fin Si

Fin Para

Escribir "triangulos equilateros", cant1

escribir "triangulos isoceles", cant2

Escribir "triangulos escalenos", cant3

Si cant1

Escribir "hubo menos triangulos equilatero"

Sino

Si cant2

Escribir

...

Descargar como  txt (27.8 Kb)   pdf (118.3 Kb)   docx (54.8 Kb)  
Leer 13 páginas más »
Disponible sólo en Essays.club